hadoop-hdfs-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Colin Patrick McCabe (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HDFS-3492) fix some misuses of InputStream#skip
Date Sun, 03 Jun 2012 20:06:23 GMT
Colin Patrick McCabe created HDFS-3492:

             Summary: fix some misuses of InputStream#skip
                 Key: HDFS-3492
                 URL: https://issues.apache.org/jira/browse/HDFS-3492
             Project: Hadoop HDFS
          Issue Type: Bug
         Environment: It seems that we have a few cases where programmers are calling InputStream#skip
and not handling "short skips."  Unfortunately, the skip method is documented and implemented
so that it doesn't actually skip the requested number of bytes, but simply tries to skip at
most that amount of bytes.  A better name probably would have been trySkip or similar.

It seems like most of the time when the argument to skip is small enough, we'll succeed almost
all of the time.  This is no doubt an implementation artifact of some of the popular stream
implementations.  This tends to hide the bug-- however, it is still waiting to emerge at some
point if those implementations ever change or if buffer sizes are adjusted, etc.

All of these cases can be fixed by calling IOUtils#skipFully to get the behavior that the
programmer expects-- i.e., skipping by the specified amount.
            Reporter: Colin Patrick McCabe
            Assignee: Colin Patrick McCabe
            Priority: Minor

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message