hadoop-hdfs-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "LIU, Lin" <wangling1...@gmail.com>
Subject Re: unable to resolve the heap space error even when running the examples
Date Fri, 13 Apr 2012 07:37:45 GMT
Hi Srikanth,

I've tried the Pi Estimator in Ubuntu 11.04 and with Hadoop 1.0.2
release. I've met the problem when I run hadoop in standalone. When I
start hadoop in Pseudo-Distributed mode, errors are gone.

If you've followed hadoop's official guide to configure  the
Pseudo-Distributed mode, please check whether you have started the
hadoop nodes before you run the example. The quickest way to check is
to access the following two addresses in your browser to see whether
hadoop is runing
    NameNode - http://localhost:50070/
    JobTracker - http://localhost:50030/

If none of above address are accessible, please run bin/start-all.sh
from the hadoop root directory.

By the way the Java I'm using is java-6-openjdk.

Regards,
Lin.

On 12 April 2012 14:57, SRIKANTH KOMMINENI (RIT Student)
<sxk7699@rit.edu> wrote:
> Hello,
>
> I have searched a lot and still cant find any solution that can fix my
> problem.
>
> I am using the the basic downloaded version of hadoop-1.0.2 and I have
> edited only what has been asked in the setup page of hadoop and I have set
> it up to work in a pseudo random distributed mode.
>
> My JAVA_HOME is set to /usr/lib/jvm/java-6-sun, I tried editing the heap
> size in hadoop-env.sh that didn't work. I tried setting the CHILD_OPTS
> that didn't work, I found that there was another hadoop-env.sh in
> /etc/hadoop/ as per the recommendations in the mailing
> list archives that didn't work . I tried increasing the  io.sort.mb
> that didn't work. I am totally frustrated but it still doesn't work.please
> help.
>
>
> --
> Srikanth Kommineni,
> Graduate Assistant,
> Dept of Computer Science,
> Rochester Institute of Technology.

Mime
View raw message