hadoop-hdfs-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mingjie Lai (Created) (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HDFS-2962) jsvc needs to be removed from hdfs packaging
Date Fri, 17 Feb 2012 07:46:00 GMT
jsvc needs to be removed from hdfs packaging

                 Key: HDFS-2962
                 URL: https://issues.apache.org/jira/browse/HDFS-2962
             Project: Hadoop HDFS
          Issue Type: Bug
          Components: data-node, security
    Affects Versions: 0.23.0
            Reporter: Mingjie Lai
             Fix For: 0.23.1

As we discussed at HDFS-2303:

... hit the same problem today when I started to try secured DN of 0.23. The shipped jsvc
(commons-daemon-1.0.3) with 0.23 doesn't work on my local ubuntu 11.10 (as described by atm,
with libcap.2 instead of 1), nor our cluster centos 5 (without any libcap).

The problem doesn't happen to 0.20.205 (what we use now) since commons-daemon-1.0.2 jsvc binary
doesn't link to any libcap (http://archive.apache.org/dist/commons/daemon/binaries/1.0.2/linux/commons-daemon-1.0.2-bin-linux-${os-arch}.tar.gz)

So the current way - downloading jsvc binary - won't work for 0.23+ secured DN. 

jsvc shouldn't be bundled with hadoop. Instead, it should be installed by user. 

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message