hadoop-hdfs-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tanping Wang (JIRA)" <j...@apache.org>
Subject [jira] Created: (HDFS-1674) HDFS Federation: Rename BlockPool class to BlockPoolSlice
Date Mon, 28 Feb 2011 21:42:37 GMT
HDFS Federation: Rename BlockPool class to BlockPoolSlice 

                 Key: HDFS-1674
                 URL: https://issues.apache.org/jira/browse/HDFS-1674
             Project: Hadoop HDFS
          Issue Type: Sub-task
          Components: data-node
    Affects Versions: Federation Branch
            Reporter: Tanping Wang
            Assignee: Tanping Wang
            Priority: Minor
             Fix For: Federation Branch

HDFS Federation (porting):
The class BlockPool is poorly named as it does not represent an actual BlockPool, but rather
that slice of the overall BlockPool for which a single DataNode is responsible.  Renames BlockPool,
BlockPoolStorage, BlockPoolScanner to BlockPoolSlice*.  Moves BlockPookSlice out of FSDataSet
to a stand-alone class.  Updates references to these structures.  Other references to BlockPools
seem appropriate in the context of the code.

This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message