hadoop-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kumar Ravi <kum...@us.ibm.com>
Subject Fw: Failing 2 junit tests in hadoop-1.0.1
Date Tue, 06 Mar 2012 15:23:08 GMT


I am not sure if I sent the below e-mail to the right e-mail list.

I am resending to this list. If neither of these e-mail lists are the right
ones, can someone please let me know where I can get this question
answered?

Thanks,

Kumar Ravi

----- Forwarded by Kumar Ravi/Austin/IBM on 03/06/2012 09:20 AM -----
                                                                                         
                                         
  From:       Kumar Ravi/Austin/IBM                                                      
                                         
                                                                                         
                                         
  To:         common-dev@hadoop.apache.org                                               
                                         
                                                                                         
                                         
  Date:       03/05/2012 03:29 PM                                                        
                                         
                                                                                         
                                         
  Subject:    Failing 2 junit tests in hadoop-1.0.1                                      
                                         
                                                                                         
                                         



Hello,

 I am seeing failures running these two tests for hadoop-1.0.1 from
svn.apache.org and using Sun/oracle Java ver. 1.6.0_31.

1. Test org.apache.hadoop.mapred.TestTTResourceReporting

2. Test org.apache.hadoop.streaming.TestUlimit


On the TTResourceReporting test, the error was an IOException --

Testcase: testConfiguredResourceValues took 85.934 sec
        Caused an ERROR
Job failed!
java.io.IOException: Job failed!
        at org.apache.hadoop.mapred.JobClient.runJob(JobClient.java:1265)
        at org.apache.hadoop.examples.SleepJob.run(SleepJob.java:174)
        at org.apache.hadoop.examples.SleepJob.run(SleepJob.java:237)
        at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:65)
        at org.apache.hadoop.mapred.TestTTResourceReporting.runSleepJob
(TestTTResourceReporting.java:342)
        at
org.apache.hadoop.mapred.TestTTResourceReporting.testConfiguredResourceValues
(TestTTResourceReporting.java:296)


On Ulimit test. I am seeing the same symptoms reported and resolved by
https://issues.apache.org/jira/browse/HADOOP-3372

This is the error I am seeing:

Testcase: testCommandLine took 86.104 sec
        FAILED
output is wrong expected:<[786432]> but was:<[]>
junit.framework.ComparisonFailure: output is wrong expected:<[786432]> but
was:<[]>
        at org.apache.hadoop.streaming.TestUlimit.runProgram
(TestUlimit.java:123)
        at org.apache.hadoop.streaming.TestUlimit.testCommandLine
(TestUlimit.java:89)

I have tried different values for ulimit on my RHEL 6.1 system on x86_64. I
also tried ant versions 1.8.2 as well as ant-1.7.1.


I would appreciate any ideas on what I might have setup incorrectly in my
environment.

Regards,

Kumar Ravi


Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message