hadoop-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott Carey <sc...@richrelevance.com>
Subject Re: Hadoop Java Versions
Date Wed, 22 Jun 2011 20:27:29 GMT
"Problems have been reported with Hadoop, the 64-bit JVM and Compressed
Object References (the -XX:+UseCompressedOops option), so use of that
option is discouraged."

I think the above is dated.  It also lacks critical information. What JVM
and OS version was the problem seen?

CompressedOops had several issues prior to Jre 6u20, and a few minor ones
were fixed in u21.  FWIW, I now exclusively use 64 bit w/ CompressedOops
for all Hadoop and non-Hadoop apps and have seen no issues.  It is the
default in 6u24 and 6u25 on a 64 bit JVM.

On 6/14/11 5:16 PM, "Allen Wittenauer" <aw@apache.org> wrote:

>
>While we're looking at the wiki, could folks update
>http://wiki.apache.org/hadoop/HadoopJavaVersions with whatever versions
>of Hadoop they are using successfully?
>
>Thanks.
>
>P.S., yes, I'm thinking about upgrading ours. :p


Mime
View raw message