hadoop-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ted Yu <yuzhih...@gmail.com>
Subject Re: Exception in thread "main" java.lang.ClassNotFoundException in Hadoop
Date Mon, 12 Jul 2010 15:44:47 GMT
Please give the commandline you used.
You should have specified the jar containing WordCount class.

On Mon, Jul 12, 2010 at 5:15 AM, james isaac <jamesisaac.dell@gmail.com>wrote:

> Hi,
>
> I have just started my career with Hadoop. I tried to execute the example
> given in
> http://hadoop.apache.org/common/docs/r0.20.1/mapred_tutorial.htmlas
> explained in the tutorial. I was not able to execute the program as
> described in the tutorial. I am getting the error as shown below. I tried
> executing with some other examples. They are also showing the same
> “ClassNotFoundException”. I tried to find the solution in various websites
> but i could not find it. Please help me to find the problem.
>
> Exception in thread "main"
> java.lang.ClassNotFoundException: org.myorg.WordCount
> at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
> at java.security.AccessController.doPrivileged(Native Method)
> at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
> at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
> at java.lang.Class.forName0(Native Method)
> at java.lang.Class.forName(Class.java:247)
> at org.apache.hadoop.util.RunJar.main(RunJar.java:149)
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message