hadoop-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Allen Wittenauer <awittena...@linkedin.com>
Subject Re: Native libraries on Mac
Date Fri, 12 Mar 2010 03:58:55 GMT

If you want, I can send you my patches and see if that fixes your issues.

Maybe I'll work on this tomorrow and actually get a JIRA posted, etc. lol



On 3/11/10 6:28 PM, "Jason Venner" <jason.hadoop@gmail.com> wrote:

> It is funny, I just put this together myself, my next step is figuring
> out why the libjvm.dynlib doesn't actually define the get a jvm
> instance symbol, for libhdfs. Once that is sorted out, I will have
> fuse_dfs going on the mac.
> The build stuff for solaris and macos is ugly, I have ended up hand
> hacking things to make the paths work, and because they are horrible
> hacks I don't submit them back.
> 
> On Thu, Mar 11, 2010 at 11:43 AM, Hong Tang <htang@yahoo-inc.com> wrote:
>> Right, this is similar to the instructions on hadoop-gpl-compression FAQ
>> page: http://code.google.com/p/hadoop-gpl-compression/wiki/FAQ (the last
>> question).
>> 
>> 
>> On 3/11/10 10:23 AM, "Arun C Murthy" <acm@yahoo-inc.com> wrote:
>> 
>>> Of course, please open a jira and attach the patch. Thanks!
>>> 
>>> On Mar 11, 2010, at 10:11 AM, Christopher Tubbs wrote:
>>> 
>>>> Well, I finally figured it out.
>>>> 
>>>> Apparently, the library being generated WAS i386 and not x86_64.
>>>> So, you have to set CFLAGS="-arch x86_64" prior to running "ant
>>>> compile-native"
>>>> 
>>>> Think we can get patches into 0.20.3 to fix building on a Mac?
>>>> 
>>>> Also, it would be nice if ivy could be preconfigured for grabbing
>>>> dependencies from the lib directory of the tarball, instead of
>>>> requiring them to be redownloaded.
>>>> 
>>>> Please and thanks.
>>>> 
>>>> On Tue, Mar 9, 2010 at 11:45 PM, Christopher Tubbs
>>>> <ctubbsii@gmail.com> wrote:
>>>>> I'm trying to build the native libraries for hadoop on Mac OS X
>>>>> Leopard (10.5.8) for Hadoop 0.20.1
>>>>> 
>>>>> I tried the "ant compile-native" method, but I don't have access to
>>>>> the internet. I do have a local repository though with all the
>>>>> dependencies (not to mention they are in the $HADOOP_HOME/lib). I was
>>>>> able to edit the build.xml file to point the repository to my local
>>>>> one so I could download ivy, but now ivy can't find the dependencies,
>>>>> and I can't figure out how to point ivy to my maven repository.
>>>>> 
>>>>> Since the first method didn't work, I tried applying the patch in
>>>>> HADOOP-3659 (has that been included in 0.20.2?), and got things
>>>>> working with a little messing with aclocal and friends, but when I
>>>>> run
>>>>> make, I get a ZLibCompressor.lo, missing argument for "-m" error in
>>>>> the build output before it quits.
>>>>> 
>>>>> Any help on building the native libs by either method would be
>>>>> greatly
>>>>> appreciated (preferably the second method, as ivy seems way too
>>>>> complicated and frustrating to deal with just for this little
>>>>> issue...
>>>>> unless it's something simple).
>>>>> 
>>>>> Christopher
>>>>> 
>>> 
>> 
>> 
> 
> 


Mime
View raw message