hadoop-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Tubbs <ctubb...@gmail.com>
Subject Native libraries on Mac
Date Wed, 10 Mar 2010 04:45:02 GMT
I'm trying to build the native libraries for hadoop on Mac OS X
Leopard (10.5.8) for Hadoop 0.20.1

I tried the "ant compile-native" method, but I don't have access to
the internet. I do have a local repository though with all the
dependencies (not to mention they are in the $HADOOP_HOME/lib). I was
able to edit the build.xml file to point the repository to my local
one so I could download ivy, but now ivy can't find the dependencies,
and I can't figure out how to point ivy to my maven repository.

Since the first method didn't work, I tried applying the patch in
HADOOP-3659 (has that been included in 0.20.2?), and got things
working with a little messing with aclocal and friends, but when I run
make, I get a ZLibCompressor.lo, missing argument for "-m" error in
the build output before it quits.

Any help on building the native libs by either method would be greatly
appreciated (preferably the second method, as ivy seems way too
complicated and frustrating to deal with just for this little issue...
unless it's something simple).


View raw message