hadoop-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Yang <garyya...@yahoo.com>
Subject Re: Compilation failed when compile hadoop common release-0.20.2
Date Mon, 08 Mar 2010 18:06:32 GMT
Hi Owen,

Thanks for the reply. From the link you provided, I found the build instruction. I do not
understand the option, "-Djava5.home=/usr/local/jdk1.5". Does it mean I have to use JDK 1.5?
I read somewhere it suggested to use JDK 1.6. 

Also, the very first line is "export JAVA_HOME=/path/to/32bit/jdk
". Does it mean the JAVA_HOME jdk has to be 1.5?  Please let me know.


export JAVA_HOME=/path/to/32bit/jdk
export CFLAGS=-m32
export CXXFLAGS=-m32
ant -Dversion=X.Y.Z -Dcompile.native=true -Dcompile.c++=true -Dlibhdfs=1 -Dlibrecordio=true
-Dxercescroot=/usr/local/xerces-c -Declipse.home=/usr/lib/eclipse -Dforrest.home=/usr/local/forrest
-Djava5.home=/usr/local/jdk1.5 clean api-report tar test test-c++-libhdfs
export JAVA_HOME=/path/to/64bit/jdk
export CFLAGS=-m64
export CXXFLAGS=-m64
ant -Dversion=X.Y.Z -Dcompile.native=true -Dcompile.c++=true compile-core-native compile-c++
tar


Thanks,


Gary



--- On Fri, 3/5/10, Owen O'Malley <omalley@apache.org> wrote:

> From: Owen O'Malley <omalley@apache.org>
> Subject: Re: Compilation failed when compile hadoop common release-0.20.2
> To: general@hadoop.apache.org
> Date: Friday, March 5, 2010, 4:32 PM
> 
> On Mar 5, 2010, at 3:47 PM, Gary Yang wrote:
> 
> > Hi,
> > 
> > I try to compile hadoop common of the release 0.20.2.
> Below are the error messages and java and ant versions I am
> using. Please tell me what I missed.
> 
> Forrest, which we use to generate the documentation,
> requires java 5. Therefore, run:
> 
> ant -Djava5.home=/some/path/to/java5 tar
> 
> There are several more you need. For a more complete list,
> I'd look at the how to release page:
> 
> http://wiki.apache.org/hadoop/HowToRelease
> 
> -- Owen
> 


      

Mime
View raw message