hadoop-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Todd Lipcon <t...@cloudera.com>
Subject 0.20.2 HDFS incompatible with 0.20.1
Date Tue, 05 Jan 2010 19:29:16 GMT
Hey all,

In a recent discussion, we noticed that the 0.20.2 HDFS client will not be
wire-compatible with 0.20.0 or 0.20.1 due to the inclusion of HDFS-793
(required for HDFS-101). This begs a few questions:

1) Although we certainly do not guarantee wire compatibility between minor
versions (0.20 -> 0.21) have we previously implied wire compatibility
between bugfix releases?

2) Is the above something we *should* be guaranteeing already?

3) If we haven't guaranteed the above, how many users think we have? (ie how
do we correctly call out this fact in the 0.20.2 release notes in such a way
that no one gets surprised). I can imagine plenty of organizations where a
lockstep upgrade between client and server is difficult, and we should make
sure that cluster operators know it will be necessary. Since it wasn't
necessary between 0.20.0 and 0.20.1, or various 0.18 releases, people may
have grown used to non-lockstep upgrades.

4) If the above are problems, would it be worth considering a patch for
branch-20 that provides a client that is compatible with either, based on
the datanode protocol version number of the server? It seems like a bit of
scary complexity, but wanted to throw it out there.

Thanks
-Todd

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message