hadoop-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tim robertson <timrobertson...@gmail.com>
Subject Re: My secondary namenode seem not be running, and may be the reason of my problem!!!
Date Fri, 03 Jul 2009 09:26:38 GMT
"at this stage the shell is blocked unless I press the enter key" - my
cluster did this until I realised passphraseless ssh was not working
between the master and the nodes and the master to itself.
http://fak3r.com/2006/08/10/howto-passwordless-ssh-logins/

Cheers,

Tim



On Fri, Jul 3, 2009 at 11:21 AM, C J<xine.jar@googlemail.com> wrote:
> Hallo everyone,
> I have installed the hadoop 0.18.3 on three linux machines, I am trying to
> run the
> example of WordCountv1.0 on a cluster. But I guess I have a problem
> somewhere.
> *
> Problem*
>
> *After formating the name node:*
> I am getting several STARTUP_MSG and at the end a "SHUTDOWN_MSG: shutting
> down the namenode..."
> is this normal?
>
> *Afterwards I try starting the dfs:**
> *I get a message "starting namenode..."* *afterwards I get another message
> "starting secondary namenode"
> at this stage the shell is blocked unless I press the enter key. Then the
> system tries to start another secondary
> namenode and the shell is then not blocked. What is going on?
> *
> Then I proceed an try starting the mapred:*
> I get the two messages "starting jobtracker....." and "starting tasktracker"
>
> *Following the tutorial for runnin WordCode v1.0, If I try to list the files
> in the input folder I have created
> *I get the famous error "Retrying connect to server:134.130.222.20:9000"
> .what am I doing something wrong?
>
>
> *Steps I have already verified*
>
> *I have already checked the iptables of the three machines and they look**:
> **
> *Chain INPUT (policy ACCEPT)
> target         prot opt source destiantion
>
> Chain FORWARD (policy ACCEPT)
> target         prot opt source destination
>
> Chain OUTPUT (policy ACCEPT)
> target        prot opt source destination
>
> *
> My hadoop-site.xml file looks like this
> * configuration>
>    <property>
>        <name>fs.default.name</name>
>        <value>134.130.222.20:9000/</value>
>    </property>
>    <property>
>        <name>mapred.job.tracker</name>
>        <value>134.130.222.18:9001</value>
>    </property>
>    ........
> </configuration>
>
> *Can someone help me out?*
> *Thank you, CJ*
>

Mime
View raw message