Dear all,
My problem with "ipc.Client: Retrying connect to server" is still open! To start a new and clean thread, here is the problem description.

[mahmood@tiger Index]$ which hadoop
[mahmood@tiger Index]$ cat /etc/hosts       localhost.localdomain localhost    tiger  orca    zardalou 

[mahmood@tiger Index]$ hadoop -jar indexdata.jar `pwd`/result hdfs://
Warning: $HADOOP_HOME is deprecated.
15/05/04 10:14:07 INFO ipc.Client: Retrying connect to server: localhost.localdomain/ Already tried 9 time(s); retry policy is RetryUpToMaximumCountWithFixedSleep(maxRetries=10, sleepTime=1 SECONDS)
Exception in thread "main" Call to localhost.localdomain/ failed on connection exception: Connection refused
        at org.apache.hadoop.ipc.Client.wrapException(
        at org.apache.hadoop.ipc.RPC$Invoker.invoke(
        at com.sun.proxy.$Proxy1.getProtocolVersion(Unknown Source)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(
        at java.lang.reflect.Method.invoke(
        at com.sun.proxy.$Proxy1.getProtocolVersion(Unknown Source)
        at org.apache.hadoop.ipc.RPC.checkVersion(
        at org.apache.hadoop.hdfs.DFSClient.createNamenode(
        at org.apache.hadoop.hdfs.DFSClient.<init>(
        at org.apache.hadoop.hdfs.DFSClient.<init>(
        at org.apache.hadoop.hdfs.DistributedFileSystem.initialize(
        at org.apache.hadoop.fs.FileSystem.createFileSystem(
        at org.apache.hadoop.fs.FileSystem.access$200(
        at org.apache.hadoop.fs.FileSystem$Cache.get(
        at org.apache.hadoop.fs.FileSystem.get(
        at IndexHDFS.indexData(
        at IndexHDFS.main(
Caused by: Connection refused
        at Method)
        at org.apache.hadoop.ipc.Client$Connection.setupConnection(
        at org.apache.hadoop.ipc.Client$Connection.setupIOstreams(
        at org.apache.hadoop.ipc.Client$Connection.access$2200(
        at org.apache.hadoop.ipc.Client.getConnection(
        ... 20 more

As you can see there are many "connection refused" errors. So you may suggest to check the firewall and network configs to make sure port #9000 is open. I found a good test method here,
This is a simple socket test program where a client send a text to the server via a port number. I have to say that I ran the program with port #9000 and **it did work successfully**

So,I am sure that there is no problem with the network configs.

Is there any idea on the hdfs://