hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brahma Reddy Battula <brahmareddy.batt...@hotmail.com>
Subject RE: ResourceLocalizationService: Localizer failed when running pi example
Date Sun, 19 Apr 2015 16:16:47 GMT
As Alexander Alten-Lorenz pointed, it mostly config issue(yarn.nodemanager.local-dirs or mapred.local.dir)..
can you able provide full logs..?
Bytheway NPE is handled in  Trunk ..Please check HADOOP-8436 for more details..

From: wget.null@gmail.com
Subject: Re: ResourceLocalizationService: Localizer failed when running pi example
Date: Sun, 19 Apr 2015 17:59:13 +0200
To: user@hadoop.apache.org

As you said, that looks like a config issue. I would spot on the NM's local scratch dir (yarn.nodemanager.local-dirs).
But without a complete stack trace, its a blind call.
BR, AL
--mapredit.blogspot.com
On Apr 18, 2015, at 6:24 PM, Fernando O. <fotero@gmail.com> wrote:Hey All,    It's me
again with another noob question: I deployed a cluster (HA mode) everything looked good but
when I tried to run the pi example:
 bin/hadoop jar ./share/hadoop/mapreduce/hadoop-mapreduce-examples-2.6.0.jar pi 16 100

the same error occurs if I try to generate data with teragen 100000000 /test/data

2015-04-18 15:49:04,090 INFO org.apache.hadoop.yarn.server.nodemanager.containermanager.localizer.ResourceLocalizationService:
Localizer failedjava.lang.NullPointerException	at org.apache.hadoop.fs.LocalDirAllocator$AllocatorPerContext.confChanged(LocalDirAllocator.java:268)
at org.apache.hadoop.fs.LocalDirAllocator$AllocatorPerContext.getLocalPathForWrite(LocalDirAllocator.java:344)
at org.apache.hadoop.fs.LocalDirAllocator.getLocalPathForWrite(LocalDirAllocator.java:150)
at org.apache.hadoop.fs.LocalDirAllocator.getLocalPathForWrite(LocalDirAllocator.java:131)
at org.apache.hadoop.fs.LocalDirAllocator.getLocalPathForWrite(LocalDirAllocator.java:115)
at org.apache.hadoop.yarn.server.nodemanager.LocalDirsHandlerService.getLocalPathForWrite(LocalDirsHandlerService.java:420)
at org.apache.hadoop.yarn.server.nodemanager.containermanager.localizer.ResourceLocalizationService$LocalizerRunner.run(ResourceLocalizationService.java:1075)

I'm guessing it's a configuration issue but I don't know what am I missing :S

 		 	   		  
Mime
View raw message