hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anand Murali <anand_vi...@yahoo.com>
Subject Deprecation Error
Date Tue, 14 Apr 2015 09:52:26 GMT
Hi:
I am using Tom Whyte's text book on Hadoop 2.X for learning. However I have installed 2.6
and using text code to get started. I get the following error on the main class

anand_vihar@Latitude-E5540:~/hadoop-2.6.0/code$ javac -classpath $(hadoop classpath) MaxTemperature.java

MaxTemperature.java:25: error: cannot find symbol
        job.setMapperClass(MaxTemperatureMapper.class);
                           ^
  symbol:   class MaxTemperatureMapper
  location: class MaxTemperature
MaxTemperature.java:26: error: cannot find symbol
        job.setReducerClass(MaxTemperatureReducer.class);
                            ^
  symbol:   class MaxTemperatureReducer
  location: class MaxTemperature
Note: MaxTemperature.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
2 errors
Can somebody advise me what are the equivalent API for setMapperClass/SetReducer class, and
where I can find the delta differences between 2.x and 2,6.

Thanks,
Regards,


 Anand Murali  11/7, 'Anand Vihar', Kandasamy St, MylaporeChennai - 600 004, IndiaPh: (044)-
28474593/ 43526162 (voicemail)
Mime
View raw message