hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Naganarasimha G R (Naga)" <garlanaganarasi...@huawei.com>
Subject RE: ResourceManager debugging
Date Sun, 03 Aug 2014 06:53:32 GMT
Hi Yehia ,

    One of the possible reasons are that the jar and the code being debugged is not in sync.
Or the line where the debug point is put is actually not reached.

Apart from the above i am not sure of your scenaro which you want to debug, so i will not
be able to take a guess !



Regards,

Naga



Huawei Technologies Co., Ltd.
Phone:
Fax:
Mobile:  +91 9980040283
Email: naganarasimhagr@huawei.com<mailto:naganarasimhagr@huawei.com>
Huawei Technologies Co., Ltd.
Bantian, Longgang District,Shenzhen 518129, P.R.China
http://www.huawei.com

¬°This e-mail and its attachments contain confidential information from HUAWEI, which is intended
only for the person or entity whose address is listed above. Any use of the information contained
herein in any way (including, but not limited to, total or partial disclosure, reproduction,
or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive
this e-mail in error, please notify the sender by phone or email immediately and delete it!

________________________________
From: Yehia Elshater [y.z.elshater@gmail.com]
Sent: Sunday, August 03, 2014 10:01
To: user@hadoop.apache.org
Subject: Re: ResourceManager debugging

Hi Naga,

Thanks a lot for your help. I have submitted multiple MapReduce jobs, the debugger is attached
successfully to eclipse and I put a breakpoint in org.apache.hadoop.yarn.server.resourcemanager.ResourceManager,
but, eclipse debugger still waits without any interruption. However, I put another breakpoint
in another class (for example RMAppAttemptContainerAllocatedEvent), the debugger reached the
code. Do you have any idea why ResourceManager code was not reachable by the debugger?

Thanks


On 2 August 2014 08:04, Naganarasimha G R (Naga) <garlanaganarasimha@huawei.com<mailto:garlanaganarasimha@huawei.com>>
wrote:

Hi Yehia ,

    I set  "YARN_RESOURCEMANAGER_OPTS" in "<installation folder>/bin/yarn"  and i was
able to debug.



 YARN_RESOURCEMANAGER_OPTS="$YARN_RESOURCEMANAGER_OPTS -Xdebug -Xrunjdwp:server=y,transport=dt_socket,address=7089,suspend=n"



Regards,

Naga



Huawei Technologies Co., Ltd.
Phone:
Fax:
Mobile:  +91 9980040283<tel:%2B91%209980040283>
Email: naganarasimhagr@huawei.com<mailto:naganarasimhagr@huawei.com>
Huawei Technologies Co., Ltd.
Bantian, Longgang District,Shenzhen 518129, P.R.China
http://www.huawei.com

¬°

This e-mail and its attachments contain confidential information from HUAWEI, which is intended
only for the person or entity whose address is listed above. Any use of the information contained
herein in any way (including, but not limited to, total or partial disclosure, reproduction,
or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive
this e-mail in error, please notify the sender by phone or email immediately and delete it!
________________________________
From: Yehia Elshater [y.z.elshater@gmail.com<mailto:y.z.elshater@gmail.com>]
Sent: Saturday, August 02, 2014 09:22
To: user@hadoop.apache.org<mailto:user@hadoop.apache.org>
Subject: ResourceManager debugging

Hi,

I am wondering how to remote debugging Yarn's RM using eclipse. I tried to adding the debugging
options "-Xdebug
-Xrunjdwp:transport=dt_socket,server=y,suspend=y,address=1337" to YARN_OPTS but it did not
work. Any suggestions ?

Thanks



Mime
View raw message