hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel <sumsel2000-mailingl...@yahoo.de>
Subject Access remote Linux cluster from Windows client
Date Tue, 05 Aug 2014 12:25:55 GMT
Hello everyone,

I have a remote Linux cluster which runs YARN and HDFS (Hadoop 2.4.1). Then I create a MapReduce
job that should be executed on the remote cluster. If I execute the it on a local Linux client,
it works fine. But if I try to execute the same job on a local Windows client, I receive the
error message shown at the end of this mail (taken from the log file of the Hadoop history
server).

I have searched the web and found the following bug report: https://issues.apache.org/jira/browse/YARN-1824

If I understand it correctly, the classpath problem should be solved automatically. But since
it does not work for me, I suppose that I have to configure something but I could not find
any instructions.

I have also added the parameter "mapred.remote.os" with the value "Linux" but without any
effect.

Had anyone the same problem? If so, could he/she please tell me, how he/she has solved the
problem of accessing a remote Linux cluster from a Windows client?

Regards,
Daniel


 Application application_1407230057273_0007 failed 2 times due to AM Container for appattempt_1407230057273_0007_000002
exited with exitCode: 1 due to: Exception from container-launch: org.apache.hadoop.util.Shell$ExitCodeException:
/bin/bash: line 0: fg: no job control
org.apache.hadoop.util.Shell$ExitCodeException: /bin/bash: Zeile 0: fg: Keine Job-Steuerung
in dieser Shell.
at org.apache.hadoop.util.Shell.runCommand(Shell.java:505)
at org.apache.hadoop.util.Shell.run(Shell.java:418)
at org.apache.hadoop.util.Shell$ShellCommandExecutor.execute(Shell.java:650)
at org.apache.hadoop.yarn.server.nodemanager.DefaultContainerExecutor.launchContainer(DefaultContainerExecutor.java:195)
at org.apache.hadoop.yarn.server.nodemanager.containermanager.launcher.ContainerLaunch.call(ContainerLaunch.java:300)
at org.apache.hadoop.yarn.server.nodemanager.containermanager.launcher.ContainerLaunch.call(ContainerLaunch.java:81)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)
Container exited with a non-zero exit code 1
.Failing this attempt.. Failing the application. 

Mime
View raw message