hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Devaraj k <devara...@huawei.com>
Subject RE: Decomssion datanode - no response
Date Fri, 05 Jul 2013 03:39:42 GMT
When did you add this configuration in NN conf?
  <property>
    <name>dfs.hosts.exclude</name>
    <value>/usr/local/hadoop/conf/dfs_exclude</value>
  </property>

If you have added this configuration after starting NN, it won't take effect and need to restart
NN.

If you have added this config with the exclude file before NN start, you can update the file
with new hosts and refreshNodes command can be issued, then newly updated the DN's will be
decommissioned.

Thanks
Devaraj k

From: Azuryy Yu [mailto:azuryyyu@gmail.com]
Sent: 05 July 2013 08:48
To: user@hadoop.apache.org
Subject: Re: Decomssion datanode - no response

Thanks Devaraj,

There are no any releated logs in the NN log and DN log.

On Fri, Jul 5, 2013 at 11:14 AM, Devaraj k <devaraj.k@huawei.com<mailto:devaraj.k@huawei.com>>
wrote:
Do you see any log related to this in Name Node logs when you issue refreshNodes dfsadmin
command?

Thanks
Devaraj k

From: Azuryy Yu [mailto:azuryyyu@gmail.com<mailto:azuryyyu@gmail.com>]
Sent: 05 July 2013 08:12
To: user@hadoop.apache.org<mailto:user@hadoop.apache.org>
Subject: Decomssion datanode - no response

Hi,
I am using hadoop-2.0.5-alpha, and I added 5 datanodes into dfs_exclude,

hdfs-site.xml:
  <property>
    <name>dfs.hosts.exclude</name>
    <value>/usr/local/hadoop/conf/dfs_exclude</value>
  </property>

then:
hdfs dfsadmin -refreshNodes

but there is no decomssion nodes showed on the webUI. and not any releated logs in the datanode
log. what's wrong?


Mime
View raw message