hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mohammad Tariq <donta...@gmail.com>
Subject Re: Prolonged safemode
Date Sun, 20 Jan 2013 12:13:45 GMT
Thank you so much for the valuable reply Harsh. I'll
look into it. One quick question, why it it happening
with 1.0.4? Is there any compulsion to set these two
props, you have specified above. Earlier version were
doing absolutely fine without these props?

I am Sorry to be a pest of questions. But, I am kinda
curious about this. Thank you so much.

Warm Regards,
Tariq
https://mtariq.jux.com/
cloudfront.blogspot.com


On Sun, Jan 20, 2013 at 4:29 PM, Harsh J <harsh@cloudera.com> wrote:

> If your DN is starting too slow, then you should investigate why.
>
> In any case, Apache Bigtop's (http://bigtop.apache.org)
> pseudo-distributed configs provide good values for 1-node setups. In your
> case, you seem to be missing dfs.safemode.min.datanodes set to 1,
> and dfs.safemode.extension set to 0.
>
>
> On Sun, Jan 20, 2013 at 4:05 AM, Mohammad Tariq <dontariq@gmail.com>wrote:
>
>> Hello list,
>>
>>        I have a pseudo distributed setup on my laptop. Everything was
>> working fine untill now. But lately HDFS has started taking a lot of time
>> to leave the safemode. Infact, I have to it manuaaly most of the times as
>> TT and Hbase daemons get disturbed because of this.
>>
>> I am using hadoop-1.0.4. Is it a problem with this version? I have never
>> faced any such issue with older versions. Or, is something going wrong on
>> my side??
>>
>> Thank you so much for your precious time.
>>
>> Warm Regards,
>> Tariq
>> https://mtariq.jux.com/
>> cloudfront.blogspot.com
>>
>
>
>
> --
> Harsh J
>

Mime
View raw message