Hi Jenny,


You should consider looking at the branch-1-win which has removed the cygwin dependency for running Hadoop on Windows.  There are vendors (Hortonworks, Microsoft) that provide free windows install packages that are simple to install as well.




From: Jennifer Lopez [mailto:lopez.mirinda@gmail.com]
Sent: Tuesday, December 11, 2012 10:08 PM
To: user@hadoop.apache.org
Subject: Reg: Permissions while running bin/hadoop


I am using Hadoop 1.1.1 to prepare a POC for a simple project. I am using Windows 7 and cygwin for the same and it is a single node setup. I have only my windows machine to use for this purpose and I login with my account that is created by my company.
I run all the commands from cygwin.

I am trying to setup the Standalone Operation and Pseudo-Distributed Operation as mentioned in the following link.
Scenario 1: Standalone Operation, no entries in the conf/*-site.xml
ran bin/hadoop jar hadoop*-exam*.jar grep input output 'dfs[a-z.]+'


12/12/12 11:05:45 ERROR security.UserGroupInformation: PriviledgedActionException as:<user-id>
cause:java.io.IOException: Failed to set permissions of path: \tmp\hadoop-<user-id>\mapred\staging\<user-id>1619674617\.staging to 0700
I tried chmod 0700 to the above folder. But the error persists.

Scenario 2: Pseudo-Distributed Operation

Made necessary changes @ conf/*-site.xml as mentioned in the above link
ran the following commands
bin/hadoop namenode
bin/hadoop datanode

my jps states that

4524 JobTracker
7120 Jps
5200 DataNode
4736 NameNode

I look at my logs and find that the tasktracker had problem starting up.

2012-12-12 11:24:47,726 ERROR org.apache.hadoop.mapred.TaskTracker: Can not start task tracker because java.io.IOException: Failed to set permissions of path: \tmp\hadoop-<user-id>\mapred\local\taskTracker to 0755
I tried chmod 0755 to the above folder. But the error persists.

When tasktracker prompts for password <user-id>@localhost's password, I enter my login password

what am I missing here? Any help would be highly appreciated.

I would not be getting any access to *nix machines nor can I install a dual OS. Company restrictions.