hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kartashov, Andy" <Andy.Kartas...@mpac.ca>
Subject notorious ClassNotFoundError
Date Fri, 16 Nov 2012 21:13:16 GMT

The notorious error. Used all possible clues to resolve this.

Ran sqoop --import.... at command line without problems. But whenever am trying to execute
MR job get Error: java.lang.ClassNotFoundException: com.cloudera.sqoop.lib.SqoopRecord

This exact same job ran before.

I can clearly see the com/cloudera/sqoop/lib/SqoopRecord.class inside  sqoop-1.4.1-cdh4.1.2.jar...

I copied this jar file to every possible directory:



As well as mapreduce-0.20 libs

Even tried to include this jar at command line -libjars which is added to the job...

But MR still doesn't pick it up, throwing ClassNotFoundError error.



NOTICE: This e-mail message and any attachments are confidential, subject to copyright and
may be privileged. Any unauthorized use, copying or disclosure is prohibited. If you are not
the intended recipient, please delete and contact the sender immediately. Please consider
the environment before printing this e-mail. AVIS : le pr?sent courriel et toute pi?ce jointe
qui l'accompagne sont confidentiels, prot?g?s par le droit d'auteur et peuvent ?tre couverts
par le secret professionnel. Toute utilisation, copie ou divulgation non autoris?e est interdite.
Si vous n'?tes pas le destinataire pr?vu de ce courriel, supprimez-le et contactez imm?diatement
l'exp?diteur. Veuillez penser ? l'environnement avant d'imprimer le pr?sent courriel

View raw message