hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harsh J <ha...@cloudera.com>
Subject Re: fixing the java / unixPrincipal hadoop error... Ubuntu.
Date Mon, 09 Jul 2012 01:27:20 GMT
Hi,

That specific class is not something Hadoop provides but does use it.

Couple of things you need to try first:
# Keep only a single java version installed, and remove gcj, etc..
Helps keep self sane.
# Have you tried a simple, explicit "export
JAVA_HOME=/path/to/jdk6u33", before you run your ant?

On Mon, Jul 9, 2012 at 3:18 AM, Jay Vyas <jayunit100@gmail.com> wrote:
> Hi guys : I run into the following roadblock in my VM - and Im not sure
> what the right way to install sun java is.  Any suggestions?
> In particular, the question is best described here:
>
> http://stackoverflow.com/questions/11288964/sun-java-not-loading-unixprincipal-ubuntu-12#comment14859324_11288964
>
> PS I posted this here because, mainly, this is a hadoop issue more than a
> pure java one, since the missing class "UnixPrincipal" Exception (i.e. you
> google for it), is mostly exclusive to the hadoop community.
>
> --
> Jay Vyas
> MMSB/UCHC



-- 
Harsh J

Mime
View raw message