hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Brown" ...@syndicate.net>
Subject RE: SafeModeException - Hadoop Startup
Date Fri, 29 Jun 2012 19:41:50 GMT
Hi Habeeb,

Please post your namenode and datanode logs.  Include everything after the
namenode and datanode processes are started.


-----Original Message-----
From: Habeeb Raza [mailto:habeebraja.abdulhameed@martini-corp.com] 
Sent: Monday, June 18, 2012 2:52 AM
To: core-user@hadoop.apache.org
Subject: SafeModeException - Hadoop Startup


Hi,

I have setup a hadoop cluster with three nodes. when I start the cluster,
all daemons are running in Master and Slave as well. while monitor from
UI(using port 50030), its showing only one node is live node(i.e, Master
node). While checking the logs, I do see the following exception.

"problem cleaning system directory:
hdfs://masternode:54310/mnt/sdb1/mapred/system
org.apache.hadoop.ipc.RemoteException:
org.apache.hadoop.hdfs.server.namenode.SafeModeException: Cannot delete
/mnt/sdb1/mapred/system. Name node is in safe mode.
The ratio of reported blocks 0.0000 has not reached the threshold 0.9990.
Safe mode will be turned off automatically."

I also tried to restart the node and restart the cluster. But its not
working.

Can anyone help me please.

Thanks in Advance,
Habeeb
--
View this message in context:
http://old.nabble.com/SafeModeException----Hadoop-Startup-tp34028890p3402889
0.html
Sent from the Hadoop core-user mailing list archive at Nabble.com.


Mime
View raw message