hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From EDUARDO ANTONIO BUITRAGO ZAPATA <eduardobuitr...@gmail.com>
Subject Re: hadoop eclipse maven problem
Date Tue, 08 May 2012 02:46:03 GMT
Hi,

I found the solution at this
post<http://code.google.com/p/protobuf/issues/detail?id=213>,
it was only executing ldconfig and the mvn eclipse:eclipse command works ?.
A few errors appears in eclipse but I think that is ok for now.

Eduardo

2012/5/7 EDUARDO ANTONIO BUITRAGO ZAPATA <eduardobuitrago@gmail.com>

> Hi everybody,
>
>
>
> I am trying to get the source of hadoop into eclipse, to do that i did the
> following
>
>
>
> 1.            svn checkout
> http://svn.apache.org/repos/asf/hadoop/common/trunk hadoop-trunk, in the
> workspace folder
>
> 2.            In the hadoop-trunk. mvn eclipse:eclipse (I installed maven
> 3 because it is required)
>
>
>
> When the last command finishes, the following errors appear
>
>
>
> [INFO] hadoop-yarn-server-tests .......................... SKIPPED
>
> [INFO] hadoop-mapreduce-client ........................... SKIPPED
>
> [INFO] hadoop-mapreduce-client-core ...................... SKIPPED
>
> [INFO] hadoop-yarn-applications .......................... SKIPPED
>
> [INFO] hadoop-yarn-applications-distributedshell ......... SKIPPED
>
> [INFO] hadoop-yarn-site .................................. SKIPPED
>
> [INFO] hadoop-mapreduce-client-common .................... SKIPPED
>
> [INFO] hadoop-mapreduce-client-shuffle ................... SKIPPED
>
> [INFO] hadoop-mapreduce-client-app ....................... SKIPPED
>
> [INFO] hadoop-mapreduce-client-hs ........................ SKIPPED
>
> [INFO] hadoop-mapreduce-client-jobclient ................. SKIPPED
>
> [INFO] Apache Hadoop MapReduce Examples .................. SKIPPED
>
> [INFO] hadoop-mapreduce .................................. SKIPPED
>
> [INFO] Apache Hadoop MapReduce Streaming ................. SKIPPED
>
> [INFO] Apache Hadoop Distributed Copy .................... SKIPPED
>
> [INFO] Apache Hadoop Archives ............................ SKIPPED
>
> [INFO] Apache Hadoop Rumen ............................... SKIPPED
>
> [INFO] Apache Hadoop Extras .............................. SKIPPED
>
> [INFO] Apache Hadoop Tools Dist .......................... SKIPPED
>
> [INFO] Apache Hadoop Tools ............................... SKIPPED
>
> [INFO] Apache Hadoop Distribution ........................ SKIPPED
>
> [INFO] Apache Hadoop Client .............................. SKIPPED
>
> [INFO] Apache Hadoop Mini-Cluster ........................ SKIPPED
>
> [INFO]
> ------------------------------------------------------------------------
>
> [INFO] BUILD FAILURE
>
> [INFO]
> ------------------------------------------------------------------------
>
> [INFO] Total time: 5.989s
>
> [INFO] Finished at: Mon May 07 17:19:00 COT 2012
>
> [INFO] Final Memory: 20M/50M
>
> [INFO]
> ------------------------------------------------------------------------
>
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-antrun-plugin:1.6:run (compile-proto) on
> project hadoop-common: An Ant BuildException has occured: exec returned:
> 127 -> [Help 1]
>
> [ERROR]
>
> [ERROR] To see the full stack trace of the errors, re-run Maven with the
> -e switch.
>
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
>
> [ERROR]
>
> [ERROR] For more information about the errors and possible solutions,
> please read the following articles:
>
> [ERROR] [Help 1]
> http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
>
> [ERROR]
>
> [ERROR] After correcting the problems, you can resume the build with the
> command
>
> [ERROR]   mvn <goals> -rf :hadoop-common
>
>
>
> I thought that the problem was that I haven’t  installed protobuf (see  this
> link<http://mail-archives.apache.org/mod_mbox/hadoop-common-user/201203.mbox/%3CCAOcnVr1XqkKMf6TPXVM8QEEvcSEAcpYPEdKxeqrbqgdHACVfjg@mail.gmail.com%3E>)
>  so installed<http://svn.apache.org/repos/asf/hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/README>,
> but I still have the problem.
>
>
>
> I’m using Ubuntu 10.04 LTS
>
>
>
> What do you guys suggest me to do?
>
>
>
> Thanks in advance.
>
>
> Eduardo
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message