hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jun Ping Du" <...@vmware.com>
Subject RE: Problem in setting up Hadoop Multi-Node Cluster using a "ROUTER"
Date Thu, 23 Feb 2012 07:15:00 GMT
Hi Guruprasad,
    Do you have the valid IP<-->hostname setting in /etc/hosts so that
each nodes can be accessed by hostname? I guess the configuration over
public network can work may because it can get hostname resolved by DNS. 

Thanks,

Junping

-----Original Message-----
From: Guruprasad B [mailto:guruprasadkini@gmail.com] 
Sent: Thursday, February 23, 2012 2:43 PM
To: core-user@hadoop.apache.org
Cc: Robin Mueller-Bady
Subject: Problem in setting up Hadoop Multi-Node Cluster using a "ROUTER"

Hello everyone.

I have facing a problem on installation of hadoop multinode cluster when I
connecte all the linux box througth a router. I have succeeded in
installing single node cluster and multi node cluster over internet(LAN).
I want to test the multi node cluster by establishing private network
between all the nodes through a router which assigns private IP address.

I am keeping the same configuration which i used to test multi node
cluster over internet(LAN).

Error:
With the router setup wen i run word count example, the program gets
hanged in the middle. it will complete map 100% and will get stop when
reduce reaches around 20%.
I gave namenode format many times and tried to run the program but still
no luck :(. one unlucky thing is there is no error in log files of both
master and slave machine.

Please let me know what could be the problem.

Quick response is very much appreciated.

Thanks & Regards,
Guruprasad

Mime
View raw message