hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ravi Prakash <ravihad...@gmail.com>
Subject Re: 0 tasktrackers in jobtracker but all datanodes present
Date Thu, 12 Jan 2012 23:50:11 GMT
Courtesy Kihwal and Bobby

Have you tried increasing the max heap size with -Xmx? and make sure that
you have swap enabled.

On Wed, Jan 11, 2012 at 6:59 PM, Gaurav Bagga <gbagga17@gmail.com> wrote:

> Hi
>
> hadoop-0.19
> I have a working hadoop cluster which has been running perfectly for
> months.
> But today after restarting the cluster, at jobtracker UI its showing state
> INITIALIZING for a long time and is staying on the same state.
> The nodes in jobtracker are zero whereas all the nodes are present on the
> dfs.
> It says Safe mode is on.
> grep'ed on slaves and I see the tasktrackers running.
>
> In namenode logs i get the following error
>
>
> 2012-01-11 16:50:57,195 WARN  ipc.Server - Out of Memory in server select
> java.lang.OutOfMemoryError: Java heap space
>        at java.nio.HeapByteBuffer.<init>(HeapByteBuffer.java:39)
>        at java.nio.ByteBuffer.allocate(ByteBuffer.java:312)
>        at
> org.apache.hadoop.ipc.Server$Connection.readAndProcess(Server.java:804)
>        at org.apache.hadoop.ipc.Server$Listener.doRead(Server.java:400)
>        at org.apache.hadoop.ipc.Server$Listener.run(Server.java:309)
>
> Not sure why the cluster is not coming up
> -G
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message