hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Kelsey <da...@gamehouse.com>
Subject Re: datanode failing to start.
Date Thu, 05 Jan 2012 02:12:17 GMT
hadoop-root-datanode-Hoot-2.local.out only shows the same Exception.

d

On 1/4/2012 2:37 PM, Dave Kelsey wrote:
>
> java version 1.6.0_29
> hadoop: 0.20.203.0
>
> I'm attempting to setup the pseudo-distributed config on a mac 10.6.8.
> I followed the steps from the QuickStart 
> (http://wiki.apache.org./hadoop/QuickStart) and succeeded with Stage 
> 1: Standalone Operation.
> I followed the steps for Stage 2: Pseudo-distributed Configuration.
> I set the JAVA_HOME variable in conf/hadoop-env.sh and I changed 
> tools.jar to the location of classes.jar (a mac version of tools.jar)
> I've modified the three .xml files as described in the QuickStart.
> ssh'ing to localhost has been configured and works with passwordless 
> authentication.
> I formatted the namenode with "bin/hadoop namenode -format" as the 
> instructions say
>
> This is what I see when I run bin/start-all.sh
>
> root# bin/start-all.sh
> starting namenode, logging to 
> /Users/admin/hadoop/hadoop-0.20.203.0/bin/../logs/hadoop-root-namenode-Hoot-2.local.out
> localhost: starting datanode, logging to 
> /Users/admin/hadoop/hadoop-0.20.203.0/bin/../logs/hadoop-root-datanode-Hoot-2.local.out
> localhost: Exception in thread "main" java.lang.NoClassDefFoundError: 
> server
> localhost: Caused by: java.lang.ClassNotFoundException: server
> localhost:     at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
> localhost:     at java.security.AccessController.doPrivileged(Native 
> Method)
> localhost:     at 
> java.net.URLClassLoader.findClass(URLClassLoader.java:190)
> localhost:     at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
> localhost:     at 
> sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
> localhost:     at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
> localhost: starting secondarynamenode, logging to 
> /Users/admin/hadoop/hadoop-0.20.203.0/bin/../logs/hadoop-root-secondarynamenode-Hoot-2.local.out
> starting jobtracker, logging to 
> /Users/admin/hadoop/hadoop-0.20.203.0/bin/../logs/hadoop-root-jobtracker-Hoot-2.local.out
> localhost: starting tasktracker, logging to 
> /Users/admin/hadoop/hadoop-0.20.203.0/bin/../logs/hadoop-root-tasktracker-Hoot-2.local.out
>
> There are 4 processes running:
> ps -fax | grep hadoop | grep -v grep | wc -l
>       4
>
> They are:
> SecondaryNameNode
> TaskTracker
> NameNode
> JobTracker
>
>
> I've searched to see if anyone else has encountered this and not found 
> anything
>
> Dave Kelsey
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message