hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Daniel Cryans <jdcry...@apache.org>
Subject Re: Version of Hadoop That Will Work With HBase?
Date Tue, 06 Dec 2011 19:48:52 GMT
For the record, this thread was started from another discussion in
user@hbase. 0.20.205 does work with HBase 0.90.4, I think the OP was a
little too quick saying it doesn't.

J-D

On Tue, Dec 6, 2011 at 11:44 AM,  <jcfolsom@pureperfect.com> wrote:
>
> Sadly, CDH3 is not an option although I wish it was. I need to get an
> official release of HBase from apache to work.
>
> I've tried every version of HBase 0.89 and up with 0.20.205 and all of
> them throw EOFExceptions. Which version of Hadoop core should I be
> using? HBase 0.94 ships with a 20-append version which doesn't work
> throws an EOFException, but when I tried replacing it with the
> hadoop-core included with hadoop 0.20.205 I still get the same
> exception.
>
> Thanks
>
>
>  -------- Original Message --------
>  Subject: Re: Version of Hadoop That Will Work With HBase?
>  From: Harsh J <harsh@cloudera.com>
>  Date: Tue, December 06, 2011 2:32 pm
>  To: common-user@hadoop.apache.org
>
>  0.20.205 should work, and so should CDH3 or 0.20-append branch builds
>  (no longer maintained, after 0.20.205 replaced it though).
>
>  What problem are you facing? Have you ensured HBase does not have a
>  bad hadoop version jar in its lib/?
>
>  On Wed, Dec 7, 2011 at 12:55 AM, <jcfolsom@pureperfect.com> wrote:
>  >
>  >
>  > Hi,
>  >
>  >
>  > Can someone please tell me which versions of hadoop contain the
>  > 20-appender code and will work with HBase? According to the Hbase
> docs
>  > (http://hbase.apache.org/book/hadoop.html), Hadoop 0.20.205 should
> work
>  > with HBase but it does not appear to.
>  >
>  >
>  > Thanks!
>  >
>
>
>
>  --
>  Harsh J
>

Mime
View raw message