hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jignesh Patel <jign...@websoft.com>
Subject Re: Hbase with Hadoop
Date Thu, 13 Oct 2011 23:11:51 GMT
Is there a way to resolve this weird problem.

> bin/hbase-start.sh is supposed to start zookeeper but it doesn't start. But on the other
side if zookeeper up and running then it says 

> Couldnt start ZK at requested address of 2181, instead got: 2182. Aborting. Why? Because
clients (eg shell) wont be able to find this ZK quorum



On Oct 13, 2011, at 5:40 PM, Jignesh Patel wrote:

> Ok now the problem is
> 
> if I only use bin/hbase-start.sh then it doesn't start zookeeper.
> 
> But if I use bin/hbase-daemon.sh start zookeeper before starting bin/hbase-start.sh then
it will try to start zookeeper at port 2181 and then I have following error.
> 
> Couldnt start ZK at requested address of 2181, instead got: 2182. Aborting. Why? Because
clients (eg shell) wont be able to find this ZK quorum
> 
> 
> So I am wondering if bin/hbase-start.sh is trying to start zookeeper then while zookeeper
is not running it should start the zookeeper. I only get the error if zookeeper already running.
> 
> 
> -Jignesh
> 
> 
> On Oct 13, 2011, at 4:53 PM, Ramya Sunil wrote:
> 
>> You already have zookeeper running on 2181 according to your jps output.
>> That is the reason, master seems to be complaining.
>> Can you please stop zookeeper, verify that no daemons are running on 2181
>> and restart your master?
>> 
>> On Thu, Oct 13, 2011 at 12:37 PM, Jignesh Patel <jignesh@websoft.com> wrote:
>> 
>>> Ramya,
>>> 
>>> 
>>> Based on "Hbase the definite guide" it seems zookeeper being started by
>>> hbase no need to start it separately(may be this is changed for 0.90.4.
>>> Anyways now  following is the updated status.
>>> 
>>> Jignesh-MacBookPro:hadoop-hbase hadoop-user$ bin/start-hbase.sh
>>> starting master, logging to
>>> /users/hadoop-user/hadoop-hbase/logs/hbase-hadoop-user-master-Jignesh-MacBookPro.local.out
>>> Couldnt start ZK at requested address of 2181, instead got: 2182. Aborting.
>>> Why? Because clients (eg shell) wont be able to find this ZK quorum
>>> Jignesh-MacBookPro:hadoop-hbase hadoop-user$ jps
>>> 41486 HQuorumPeer
>>> 38814 SecondaryNameNode
>>> 41578 Jps
>>> 38878 JobTracker
>>> 38726 DataNode
>>> 38639 NameNode
>>> 38964 TaskTracker
>>> 
>>> On Oct 13, 2011, at 3:23 PM, Ramya Sunil wrote:
>>> 
>>>> Jignesh,
>>>> 
>>>> I dont see zookeeper running on your master. My cluster reads the
>>> following:
>>>> 
>>>> $ jps
>>>> 15315 Jps
>>>> 13590 HMaster
>>>> 15235 HQuorumPeer
>>>> 
>>>> Can you please shutdown your Hmaster and run the following first:
>>>> $ hbase-daemon.sh start zookeeper
>>>> 
>>>> And then start your hbasemaster and regionservers?
>>>> 
>>>> Thanks
>>>> Ramya
>>>> 
>>>> On Thu, Oct 13, 2011 at 12:01 PM, Jignesh Patel <jignesh@websoft.com>
>>> wrote:
>>>> 
>>>>> ok --config worked but it is showing me same error. How to resolve this.
>>>>> 
>>>>> http://pastebin.com/UyRBA7vX
>>>>> 
>>>>> On Oct 13, 2011, at 1:34 PM, Ramya Sunil wrote:
>>>>> 
>>>>>> Hi Jignesh,
>>>>>> 
>>>>>> "--config" (i.e. - - config) is the option to use and not "-config".
>>>>>> Alternatively you can also set HBASE_CONF_DIR.
>>>>>> 
>>>>>> Below is the exact command line:
>>>>>> 
>>>>>> $ hbase --config /home/ramya/hbase/conf shell
>>>>>> hbase(main):001:0> create 'newtable','family'
>>>>>> 0 row(s) in 0.5140 seconds
>>>>>> 
>>>>>> hbase(main):002:0> list 'newtable'
>>>>>> TABLE
>>>>>> newtable
>>>>>> 1 row(s) in 0.0120 seconds
>>>>>> 
>>>>>> OR
>>>>>> 
>>>>>> $ export HBASE_CONF_DIR=/home/ramya/hbase/conf
>>>>>> $ hbase shell
>>>>>> 
>>>>>> hbase(main):001:0> list 'newtable'
>>>>>> TABLE
>>>>>> 
>>>>>> newtable
>>>>>> 
>>>>>> 1 row(s) in 0.3860 seconds
>>>>>> 
>>>>>> 
>>>>>> Thanks
>>>>>> Ramya
>>>>>> 
>>>>>> 
>>>>>> On Thu, Oct 13, 2011 at 8:30 AM, jigneshmpatel <
>>> jigneshmpatel@gmail.com
>>>>>> wrote:
>>>>>> 
>>>>>>> There is no command like -config see below
>>>>>>> 
>>>>>>> Jignesh-MacBookPro:hadoop-hbase hadoop-user$ bin/hbase -config
>>> ./config
>>>>>>> shell
>>>>>>> Unrecognized option: -config
>>>>>>> Could not create the Java virtual machine.
>>>>>>> 
>>>>>>> --
>>>>>>> View this message in context:
>>>>>>> 
>>>>> 
>>> http://lucene.472066.n3.nabble.com/Hbase-with-Hadoop-tp3413950p3418924.html
>>>>>>> Sent from the Hadoop lucene-users mailing list archive at Nabble.com.
>>>>>>> 
>>>>> 
>>>>> 
>>> 
>>> 
> 


Mime
View raw message