hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Broberg <tbrob...@yahoo.com>
Subject Wiki quickstart comments
Date Mon, 24 Oct 2011 22:15:17 GMT
Some issues I'm seeing with the wiki at http://wiki.apache.org/hadoop/QuickStart.

I'd be happy to update, but my knowledge is still limited.

1 - Requirements
	* Java 1.6 (see HadoopJavaVersions for 1.6.X version details) 
	* ssh and sshd 
	* rsync 
ant? maven 3.x? protobuf 2.4?


2 - "Subversion: First check that the currently build isn't borked http://lucene.zones.apache.org:8080/hudson/job/Hadoop-Nightly/"

This site appears unresponsive.

3 - Then grab the latest with subversion svn co http://svn.apache.org/repos/asf/hadoop/core/trunk hadoop

run the following commands: 
cd hadoop
ant 
ant examples
bin/hadoop

The lastest will grab 0.25? >= 0.23 builds with maven, not ant, so do we need to give options
for what to grab? Tell them to use maven?

I'm sure there are many similar issues elsewhere (for example, the eclipse plugin now builds
with maven instead of ant).

Can somebody who knows what they're doing please review and update this page in particular
and the wiki in general?

Thanks,
- Tim.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message