hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bejoy KS <bejoy.had...@gmail.com>
Subject Hive and Hbase not working with cloudera VM
Date Thu, 08 Sep 2011 12:36:29 GMT
Hi
        I was using cloudera training VM to test out my map reduce codes
which was working really well. Now i do have some requirements to run
hive,hbase,Sqoop as well on on this VM for testing purposes. For hive and
hbase I'm able to log in on to the cli client, but none of the commands are
getting executed. The errors popping out are as follows

*HBase* : a simple create command
ERROR: org.apache.hadoop.hbase.ZooKeeperConnectionException:
org.apache.hadoop.hbase.ZooKeeperConnectionException:
org.apache.zookeeper.KeeperException$ConnectionLossException:
KeeperErrorCode = ConnectionLoss for /hbase

*Hive* - cmd: show tables;
FAILED: Error in metadata: javax.jdo.JDOFatalDataStoreException: Cannot get
a connection, pool error Could not create a validated object, cause: A
read-only user or a user in a read-only database is not permitted to disable
read-only mode on a connection.
NestedThrowables:
org.apache.commons.dbcp.SQLNestedException: Cannot get a connection, pool
error Could not create a validated object, cause: A read-only user or a user
in a read-only database is not permitted to disable read-only mode on a
connection.
FAILED: Execution Error, return code 1 from
org.apache.hadoop.hive.ql.exec.DDLTask

 I'm on cloudera-demo-0.3.7 demo VM . Please advise.

Thank You

Regards
Bejoy.K.S

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message