hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Payne <er...@yahoo-inc.com>
Subject RE: Cygwin not working with Hadoop and Eclipse Plugin
Date Tue, 26 Jul 2011 19:43:34 GMT
Hi A Df,

I haven't set up Hadoop under cygwin, but I use cygwin a lot.

One thing I would suggest is to use the bash shell in cygwin and use the following format
for the $PATH additions:
PATH=$PATH:/cygdrive/c/cygwin/bin:/cygdrive/c/cygwin/usr/bin

My understanding is that the stable version of Hadoop is 0.20.203.

Thanks,
-Eric

> -----Original Message-----
> From: A Df [mailto:abbey_dragonforest@yahoo.com]
> Sent: Tuesday, July 26, 2011 1:34 PM
> To: common-user@hadoop.apache.org
> Subject: Cygwin not working with Hadoop and Eclipse Plugin
> 
> Dear All:
> 
> I am trying to run Hadoop on Windows 7 so as to test programs before
> moving to Unix/Linux. I have downloaded the Hadoop 0.20.2 and Eclipse 3.6
> because I want to use the plugin. I am also using cygwin. However, I set
> the environment variable for JAVA_HOME and added the
> c:\cygwin\bin;c:\cygwin\usr\bin to the PATH variable but I still get the
> error below when trying to start the Hadoop. This is based on the
> instructions to edit the file conf/hadoop-env.sh to define at least
> JAVA_HOME to be the root of your Java installation which I changed to
> "export JAVA_HOME=/cygdrive/c/Program\ Files\ \(x86\)/Java/jdk1.6.0_26"
> with no success. I added the \ to escape special characters.
> 
> 
> Error:
> bin/hadoop: line 258: /cygdrive/c/Program: No such file or directory
> 
> 
> I also wanted to find out which is the stable release of Hadoop and which
> version of Eclipse and the Plugin should I use? So far almost every
> tutorial I have seen from Googling shows different versions like on:
> http://developer.yahoo.com/hadoop/tutorial/index.html
> OR
> http://v-lad.org/Tutorials/Hadoop/00%20-%20Intro.html
> 
> In Eclipse the WordCount project has 42 errors because it will not
> recognize the "import org.apache......" in the code.
> 
> 
> I wanted to test on Windows first to get a feel of Hadoop since I am new
> to it and also because I am newbie Unix/Linux user. I have been trying to
> follow the tutorials shown at the link above but each time I run into
> errors with the plugin or not recognizing the import or JAVA_HOME not set.
> Please can I get some help. Thanks
> 
> Cheers
> A Df

Mime
View raw message