hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From A Df <abbey_dragonfor...@yahoo.com>
Subject Re: Cygwin not working with Hadoop and Eclipse Plugin
Date Wed, 27 Jul 2011 16:07:39 GMT
See (inline at ***)


Cheers,
A Df


>________________________________
>From: Harsh J <harsh@cloudera.com>
>To: common-user@hadoop.apache.org; A Df <abbey_dragonforest@yahoo.com>
>Sent: Tuesday, 26 July 2011, 21:29
>Subject: Re: Cygwin not working with Hadoop and Eclipse Plugin
>
>A Df,
>
>On Wed, Jul 27, 2011 at 1:42 AM, A Df <abbey_dragonforest@yahoo.com> wrote:
>> Harsh:
>>
>> See (inline at the **) I hope its easy to follow and for the other responses, I was
not sure how to respond to get everything into one. Sorry for top posting!
>
>Np! I don't strongly enforce a style of reply so long as it is
>visible, and readable :)
>
>>
>> Eric where would I put the line below and explain in newbie terms, thanks:
>> PATH=$PATH:/cygdrive/c/cygwin/bin:/cygdrive/c/cygwin/usr/bin
>
>*** I have added it to the PATH variable as "$PATH:/cygdrive/c/cygwin/bin:/cygdrive/c/cygwin/usr/bin",
I hope this is correct.
>
>You'd set this in your Windows environment. A good guide (googled
>link): http://geekswithblogs.net/renso/archive/2009/10/21/how-to-set-the-windows-path-in-windows-7.aspx
>
>>>The last known version I'd heard had a no-complains, fully-working
>>>eclipse plugin along with it was Hadoop 0.20.2 (although stable is
>>>203, I've seen lots of issues pop up with eclipse plugin from members
>>>on the ML, but someone else can comment better on if its fixed for 204
>>>or is a non-issue). I've used this one personally on Windows myself
>>>and things work. I think there was just one issue one could encounter
>>>somehow and I'd covered it in a blog post some time ago, here:
>>>http://www.harshj.com/2010/07/18/making-the-eclipse-plugin-work-for-hadoop/
>>>
>>>** I tried to use the patch but my cygwin gives the error: "bash: patch: command
not found"
>
>Feared you may face it. You need to install the patch program from
>Cygwin's package manager/installer. I believe the package name is
>(iirc): patchutils
>
>*** I installed the patchutils but now when I reach the ant command it gives error: "bash:
ant: command not found". I searched for a ant plugin but I don't see any. How do I get to
run the line "ant
-Declipse.home=$ECLIPSE_HOME binary"?
>
>>>Beyond that, the tutorial at v-lad.org is the one I'd recommend
>>>following. It has worked well for me over time.
>>>
>>>** yes, the screenshots and instructions are easy to follow just that I seem to
always have a problem with the plugin or cygwin
>
>What specific error do you get when you load the plugin or start the
>daemons via cygwin shell, etc.? Its easier for folks to answer if they
>see an error message, or a stacktrace.
>
>>>> I wanted to test on Windows first to get a feel of Hadoop since I am new
to it and also because I am newbie Unix/Linux user. I have been trying to follow the tutorials
shown at the link above but each time I run into errors with the plugin or not recognizing
the import or JAVA_HOME not set. Please can I get some help. Thanks
>>>
>>>I'd say use Linux when/where possible. A VM is a good choice as well,
>>>as James pointed out above, if your hardware can handle it.
>>>
>>>** Harsh and James, I tried the vmware from the Yahoo tutorial but I had problems
with the plugin too.
>
>You can setup a raw linux VM, and install stuff atop. I've had better
>success with the VMs Cloudera offers:
>https://ccp.cloudera.com/display/SUPPORT/Cloudera's+Hadoop+Demo+VM
>(They come ready with the whole stack). But basically it all boils
>down to using a Linux VM, wherever you source it from.
>
>-- 
>Harsh J
>
>
>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message