hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From A Df <abbey_dragonfor...@yahoo.com>
Subject Re: Cygwin not working with Hadoop and Eclipse Plugin
Date Tue, 26 Jul 2011 20:12:24 GMT
Harsh:

See (inline at the **) I hope its easy to follow and for the other responses, I was not sure
how to respond to get everything into one. Sorry for top posting!


Eric where would I put the line below and explain in newbie terms, thanks:
PATH=$PATH:/cygdrive/c/cygwin/bin:/cygdrive/c/cygwin/usr/bin

EF:
I will try to reinstall Java and yes the spaces gives problems. :(


Cheers,
A Df


>________________________________
>From: Harsh J <harsh@cloudera.com>
>To: common-user@hadoop.apache.org; A Df <abbey_dragonforest@yahoo.com>
>Sent: Tuesday, 26 July 2011, 20:25
>Subject: Re: Cygwin not working with Hadoop and Eclipse Plugin
>
>A Df,
>
>(Inlines)
>
>On Wed, Jul 27, 2011 at 12:03 AM, A Df <abbey_dragonforest@yahoo.com> wrote:
>> Dear All:
>>
>> I am trying to run Hadoop on Windows 7 so as to test programs before moving to Unix/Linux.
I have downloaded the Hadoop 0.20.2 and Eclipse 3.6 because I want to use the plugin. I am
also using cygwin. However, I set the environment variable for JAVA_HOME and added the c:\cygwin\bin;c:\cygwin\usr\bin
to the PATH variable but I still get the error below when trying to start the Hadoop. This
is based on the instructions to edit the file conf/hadoop-env.sh to define at least JAVA_HOME
to be the root of your Java installation which I changed to "export JAVA_HOME=/cygdrive/c/Program\
Files\ \(x86\)/Java/jdk1.6.0_26" with no success. I added the \ to escape special characters.
>
>This looks fine.
>
>> Error:
>> bin/hadoop: line 258: /cygdrive/c/Program: No such file or directory
>
>I've encountered this before, its harmless. Your problem lies
>elsewhere. Is the Cygwin's bin/ directory on your Windows path? What
>errors do you get on submit?
>
>> I also wanted to find out which is the stable release of Hadoop and which version
of Eclipse and the Plugin should I use? So far almost every tutorial I have seen from Googling
shows different versions like on:
>> http://developer.yahoo.com/hadoop/tutorial/index.html
>> OR
>> http://v-lad.org/Tutorials/Hadoop/00%20-%20Intro.html
>>
>> In Eclipse the WordCount project has 42 errors because it will not recognize the
"import org.apache......" in the code.
>
>The last known version I'd heard had a no-complains, fully-working
>eclipse plugin along with it was Hadoop 0.20.2 (although stable is
>203, I've seen lots of issues pop up with eclipse plugin from members
>on the ML, but someone else can comment better on if its fixed for 204
>or is a non-issue). I've used this one personally on Windows myself
>and things work. I think there was just one issue one could encounter
>somehow and I'd covered it in a blog post some time ago, here:
>http://www.harshj.com/2010/07/18/making-the-eclipse-plugin-work-for-hadoop/
>
>** I tried to use the patch but my cygwin gives the error: "bash: patch: command not found"
>
>Beyond that, the tutorial at v-lad.org is the one I'd recommend
>following. It has worked well for me over time.
>
>** yes, the screenshots and instructions are easy to follow just that I seem to always
have a problem with the plugin or cygwin
>
>> I wanted to test on Windows first to get a feel of Hadoop since I am new to it and
also because I am newbie Unix/Linux user. I have been trying to follow the tutorials shown
at the link above but each time I run into errors with the plugin or not recognizing the import
or JAVA_HOME not set. Please can I get some help. Thanks
>
>I'd say use Linux when/where possible. A VM is a good choice as well,
>as James pointed out above, if your hardware can handle it.
>
>** Harsh and James, I tried the vmware from the Yahoo tutorial but I had problems with
the plugin too.
>
>Also checkout the Karmasphere's community edition tools @
>http://karmasphere.com/Download/register-for-community-edition.html --
>They require registration but were good to start with when I'd tried
>them ~1 year ago. Should be better now. Not sure if they are F/OSS but
>surely good tools.
>
>** looks good, thanks I will give it a try tomorrow
>-- 
>Harsh J
>Get CDH and more: http://www.cloudera.com/hadoop
>
>
>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message