hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From A Df <abbey_dragonfor...@yahoo.com>
Subject Cygwin not working with Hadoop and Eclipse Plugin
Date Tue, 26 Jul 2011 18:33:39 GMT
Dear All:

I am trying to run Hadoop on Windows 7 so as to test programs before moving to Unix/Linux.
I have downloaded the Hadoop 0.20.2 and Eclipse 3.6 because I want to use the plugin. I am
also using cygwin. However, I set the environment variable for JAVA_HOME and added the c:\cygwin\bin;c:\cygwin\usr\bin
to the PATH variable but I still get the error below when trying to start the Hadoop. This
is based on the instructions to edit the file conf/hadoop-env.sh to define at least JAVA_HOME
to be the root of your Java installation which I changed to "export JAVA_HOME=/cygdrive/c/Program\
Files\ \(x86\)/Java/jdk1.6.0_26" with no success. I added the \ to escape special characters.


Error:
bin/hadoop: line 258: /cygdrive/c/Program: No such file or directory


I also wanted to find out which is the stable release of Hadoop and which version of Eclipse
and the Plugin should I use? So far almost every tutorial I have seen from Googling shows
different versions like on:
http://developer.yahoo.com/hadoop/tutorial/index.html
OR
http://v-lad.org/Tutorials/Hadoop/00%20-%20Intro.html

In Eclipse the WordCount project has 42 errors because it will not recognize the "import org.apache......"
in the code.


I wanted to test on Windows first to get a feel of Hadoop since I am new to it and also because
I am newbie Unix/Linux user. I have been trying to follow the tutorials shown at the link
above but each time I run into errors with the plugin or not recognizing the import or JAVA_HOME
not set. Please can I get some help. Thanks

Cheers
A Df

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message