hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From praveenesh kumar <praveen...@gmail.com>
Subject Re: Hadoop eclipse plugin stopped working after replacing hadoop-0.20.2 jar files with hadoop-0.20-append jar files
Date Wed, 22 Jun 2011 06:37:01 GMT
I followed michael noll's tutorial for making hadoop-0-20-append jars..

http://www.michael-noll.com/blog/2011/04/14/building-an-hadoop-0-20-x-version-for-hbase-0-90-2/

After following the article.. we get 5 jar files which we need to replace it
from hadoop.0.20.2 jar file.
There is no jar file for hadoop-eclipse plugin..that I can see in my
repository if I follow that tutorial.

Also the hadoop-plugin I am using..has no info on JIRA MAPREDUCE-1280
regarding whether it is compatible with hadoop-0.20-append.

Does anyone else. faced this kind of issue ???

Thanks,
Praveenesh


On Wed, Jun 22, 2011 at 11:48 AM, Devaraj K <devaraj.k@huawei.com> wrote:

> Hadoop eclipse plugin also uses hadoop-core.jar file communicate to the
> hadoop cluster. For this it needs to have same version of hadoop-core.jar
> for client as well as server(hadoop cluster).
>
> Update the hadoop eclipse plugin for your eclipse which is provided with
> hadoop-0.20-append release, it will work fine.
>
>
> Devaraj K
>
> -----Original Message-----
> From: praveenesh kumar [mailto:praveenesh@gmail.com]
> Sent: Wednesday, June 22, 2011 11:25 AM
> To: common-user@hadoop.apache.org
> Subject: Hadoop eclipse plugin stopped working after replacing
> hadoop-0.20.2
> jar files with hadoop-0.20-append jar files
>
> Guys,
> I was using hadoop eclipse plugin on hadoop 0.20.2 cluster..
> It was working fine for me.
> I was using Eclipse SDK Helios 3.6.2 with the plugin
> "hadoop-eclipse-plugin-0.20.3-SNAPSHOT.jar" downloaded from JIRA
> MAPREDUCE-1280
>
> Now for Hbase installation.. I had to use hadoop-0.20-append compiled
> jars..and I had to replace the old jar files with new 0.20-append compiled
> jar files..
> But now after replacing .. my hadoop eclipse plugin is not working well for
> me.
> Whenever I am trying to connect to my hadoop master node from that and try
> to see DFS locations..
> it is giving me the following error:
> *
> Error : Protocol org.apache.hadoop.hdfs.protocol.clientprotocol version
> mismatch (client 41 server 43)*
>
> However the hadoop cluster is working fine if I go directly on hadoop
> namenode use hadoop commands..
> I can add files to HDFS.. run jobs from there.. HDFS web console and
> Map-Reduce web console are also working fine. but not able to use my
> previous hadoop eclipse plugin.
>
> Any suggestions or help for this issue ?
>
> Thanks,
> Praveenesh
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message