hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jagaran das <jagaran_...@yahoo.co.in>
Subject Re: NameNode is starting with exceptions whenever its trying to start datanodes
Date Tue, 07 Jun 2011 18:02:32 GMT
Sorry I mean Some of your data nodes are not  getting connected



________________________________
From: jagaran das <jagaran_das@yahoo.co.in>
To: common-user@hadoop.apache.org
Sent: Tue, 7 June, 2011 10:45:59 AM
Subject: Re: NameNode is starting with exceptions whenever its trying to start 
datanodes

Check two things:

1. Some of your data node is getting connected, that means password less SSH is 
not working within nodes.
2. Then Clear the Dir where you data is persisted in data nodes and format the 
namenode.

It should definitely work then

Cheers,
Jagaran 



________________________________
From: praveenesh kumar <praveenesh@gmail.com>
To: common-user@hadoop.apache.org
Sent: Tue, 7 June, 2011 3:14:01 AM
Subject: Re: NameNode is starting with exceptions whenever its trying to start 
datanodes

But I dnt have any data on my HDFS.. I was having some date before.. but now
I deleted all the files from HDFS..
I dnt know why datanodes are taking time to start.. I guess because of this
exception its taking more time to start.

On Tue, Jun 7, 2011 at 3:34 PM, Steve Loughran <stevel@apache.org> wrote:

> On 06/07/2011 10:50 AM, praveenesh kumar wrote:
>
> The logs say
>
>
>  The ratio of reported blocks 0.9091 has not reached the threshold 0.9990.
>> Safe mode will be turned off automatically.
>>
>
>
> not enough datanodes reported in, or they are missing data
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message