hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oran Charles <charles.o...@gmail.com>
Subject Re: Server failed to authenticate, wordcount example
Date Thu, 09 Jun 2011 09:46:37 GMT

I do not know if I have to answer to my question in this way, or edit my
question. Anyway I find the solution and I just want to tell it for everyone
who will get the same error.

After few days of research and try, I understand that Fedora and C++ on
64bits for Hadoop is not a good match. I tried to compile the Hadoop
wordcount C++ with ant like explained in the wiki. But ant gets me some
error about : libssl and stdint.
First, if you are on Fedora you have to add -lcrypto to the LIBS variables
in the .configure. That is cause the dependency on libcrypto must now be
explicitely stated on these platform when linking to libssl.(see bug on
Fedora). Second issue : ant produces a lot of error about C++ files : to
resolve that you just have to add an include : stdind.h on the top of the
file.
Then the build success. I tried then to run wordcount example on my Hadoop
cluster and it works, while mine did not. I expected that issue come from
the library that I just corrected and I was right : I tried to run Hadoop
example with library from the hadoop install directory and it did not work
and I get the same error.
That could be explained by the fact that ant recompile the C++ library
needed for Hadoop(with correction that I did) and used it, instead library
provides in the Hadoop install directory.
-- 
View this message in context: http://old.nabble.com/Server-failed-to-authenticate%2C-wordcount-example-tp31798396p31808058.html
Sent from the Hadoop core-user mailing list archive at Nabble.com.


Mime
View raw message