hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tdp2110 <thomas.d.pet...@gmail.com>
Subject Linker errors with Hadoop pipes
Date Thu, 19 May 2011 22:28:37 GMT

n00b here, just started playing around with pipes. I'm getting linker errors
while compiling a simple WordCount example using hadoop-0.20.203 (current
most recent version) that did not appear for the same code in hadoop-0.20.2

Linker errors of the form: undefined reference to `EVP_sha1' in

EVP_sha1 (and all of the undefined references I get) are part of the openssl
library which HadoopPipes.cc from hadoop-0.20.203 uses, but hadoop-0.20.2
does not.

I've tried adjusting my makefile to link to the ssl libraries, but I'm still
out of luck. Any ideas would be greatly appreciated. Thanks!

PS, here is my current makefile:
CC = g++
HADOOP_INSTALL = /usr/local/hadoop-
SSL_INSTALL = /usr/local/ssl
PLATFORM = Linux-amd64-64

WordCount: WordCount.cc
    $(CC) $(CPPFLAGS) $< -Wall -Wextra -L$(SSL_INSTALL)/lib -lssl -lcrypto
-L$(HADOOP_INSTALL)/c++/$(PLATFORM)/lib -lhadooppipes -lhadooputils
-lpthread -g -O2 -o $@

View this message in context: http://old.nabble.com/Linker-errors-with-Hadoop-pipes-tp31634596p31634596.html
Sent from the Hadoop core-user mailing list archive at Nabble.com.

View raw message