hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tanping Wang <tanp...@yahoo-inc.com>
Subject RE: hadoop installation problem(single-node)
Date Fri, 04 Mar 2011 20:00:31 GMT
Try 
$HADOOP_HOME/bin/hadoop namenode -format

or maybe consider
export PATH=$HADOOP_HOME/bin:$PATH

Regards,
Tanping
-----Original Message-----
From: Manish Yadav [mailto:manish.yadav@orkash.com] 
Sent: Wednesday, March 02, 2011 1:00 AM
To: core-user@hadoop.apache.org
Subject: hadoop installation problem(single-node)

Dear Sir/Madam
  I'm very new to hadoop. I'm trying to install hadoop on my computer. I followed a weblink
and try to install it. I want to install hadoop on my single node cluster.
i 'm using Ubuntu 10.04 64-bit as my operating system . I have installed java in /usr/java/jdk1.6.0_24.
the step i take to install hadoop are following

1: Make a group hadoop and a user hadoop with home directory in hadoop directory i have a
directory called projects and download hadoop binary there than extract them there; i configured
the ssh also.

than i made changes to some file which are following. i'm attaching them with this male please
check them .
1: hadoop_env_sh
2:core-site.xml
3mapreduce-site.xml
4 hdfs-site. xml
5 hadoop's usre .bashrc
6 hadoop'user .profile

  After making changes to these fie ,I just enter the hadoop account and enter the  few command
following thing happen :

hadoop@ws40-man-lin:~$ echo $HADOOP_HOME /home/hadoop/project/hadoop-0.20.0
hadoop@ws40-man-lin:~$ hadoop namenode -format
hadoop: command not found
hadoop@ws40-man-lin:~$ namenode -format
namenode: command not found
hadoop@ws40-man-lin:~$

now I'm completely stuck i don't know what to do? please help me as there is no more help
around the net.
i' m attaching the files also which i changed can u tell me the exact configuration which
i should use to install hadoop.



Mime
View raw message