hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jun Young Kim <juneng...@gmail.com>
Subject Re: Could not add a new data node without rebooting Hadoop system
Date Tue, 08 Feb 2011 00:56:15 GMT
how about to use to reset for your new network topology?

$> hadoop dfsadmin -refreshNodes

Junyoung Kim (juneng603@gmail.com)


On 02/07/2011 09:16 PM, Harsh J wrote:
> On Mon, Feb 7, 2011 at 5:16 PM, ahn<ahneuigun@gmail.com>  wrote:
>> Hello everybody
>> 1. configure conf/slaves and *.xml files on master machine
>>
>> 2. configure conf/master and *.xml files on slave machine
> 'slaves' and 'masters' file are generally only required in the master
> machine, and only if you are using the start-* scripts supplied with
> Hadoop for use with SSH (FAQ has an entry on this) from master.
>
>> 3. run ${HADOOP}/bin/hadoop datanode
>> But when I ran the commands on the master node, the master node was
>> recognized as a data node.
> 3. wasn't a valid command in this case. start-dfs.sh
>
>> When I ran the commands on the data node which I want to add, the data node
>> was not properly added.(The number of total data node didn't show any
>> change)
> What do the logs say for the DataNode on the slave? Does it start
> successfully? If fs.default.name is set properly in slave's
> core-site.xml it should be able to communicate properly if started
> (and if the version is not mismatched).
>

Mime
View raw message