hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Daniel Cryans <jdcry...@apache.org>
Subject Re: Hbase-hdfs CLOSE_WAIT connection problem
Date Wed, 27 Oct 2010 20:44:54 GMT
Moving to user@hbase.apache.org is more appropriate.

If you do a bit of google search, you can see that there's currently
two opened issues regarding CLOSE_WAIT:

- If you have ChecklsumExceptions, this will generate thousands of
opened sockets: https://issues.apache.org/jira/browse/HBASE-2042
- It was also discussed in this jira, also no resolution regarding
CLOSE_WAIT https://issues.apache.org/jira/browse/HBASE-2180

I'd say you should have a look at the region server log and look for
any suspicious exceptions.

Also, "closing" the HTables doesn't release any resource, so this
probably has no effect on your issue.

J-D

On Tue, Oct 26, 2010 at 11:51 PM, akhilesh.kumar
<akhilesh.kumar@zapak.co.in> wrote:
> Hi,
>
>      We are using hbase-0.20.6 with hdfs (single node setup), while pushing
> the data into hbase, using java API's, there are lots of TCP CLOSE_WAIT
> connection crops up. These connections persist for a long time, even for day
> or two. Linux setting for TCP connection is 72 sec. which are overridden by
> hbase java API. Hbase API connection with hdfs data-anode persist with
> CLOSE_WAIT (We are closing all tables after the operation but this is
> showing in netstat command). Anybody having some idea about this problem?
>
>
>
> Regards
>
> Akhilesh Kumar
>
>

Mime
View raw message