hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Allen Wittenauer <awittena...@linkedin.com>
Subject Re: WARN util.NativeCodeLoader: Unable to load native-hadoop library
Date Wed, 14 Jul 2010 16:27:23 GMT

On Jul 14, 2010, at 8:45 AM, Some Body wrote:
> I changed it back to the way it was. This is Cloudera's 0.20.2+228 release.

...

> [root@namenode] # ldd libhadoop.so.1.0.0
> ./libhadoop.so.1.0.0: /lib64/tls/libc.so.6: version `GLIBC_2.4' not found (required by
./libhadoop.so.1.0.0)

OK, here's your answer.

The glibc version that this was compiled with is (likely) newer than the one you have on your
machine.

Upgrade your glibc package or bug cloudera to build it on an older one. :)




Mime
View raw message