hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Allen Wittenauer <awittena...@linkedin.com>
Subject Re: WARN util.NativeCodeLoader: Unable to load native-hadoop library
Date Tue, 13 Jul 2010 16:47:58 GMT

On Jul 13, 2010, at 7:17 AM, Some Body wrote:
> I followed the steps from the native library guide 

We need to rewrite that guide.  It is pretty clear that we have overloaded the term native
libraries enough that no one understands what anyone else is talking about.


> 1. put the OS's libz libs in 
>      [root@namenode]# pwd
>     /opt/hadoop/lib/native
> 
>      [root@namenode]# find . -name '*libz*' 
>     ./Linux-amd64-64/libz.so.1
>     ./Linux-amd64-64/libz.so.1.2.1.2
>     ./Linux-amd64-64/libz.so
>     ./Linux-i386-32/libz.so.1
>     ./Linux-i386-32/libz.so.1.2.1.2
>     ./Linux-i386-32/libz.so 


You should have libhadoop there and it should be linked to libz.  Run ldd against libhadoop
and see what comes out.


Mime
View raw message