hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Some Body" <someb...@squareplanet.de>
Subject Re: WARN util.NativeCodeLoader: Unable to load native-hadoop library
Date Wed, 14 Jul 2010 13:07:01 GMT

On Jul 13, 2010, at 6:48 PM, Allen Wittenauer wrote:> You should have libhadoop there and
it should be linkedto libz.  

> Run ldd against libhadoop andsee what comes out.


OK, that's good input.  I got a step further but I'm still missing something.

It says it loads the native library but appatently it can't initialize it.



    [root@namenode]# hadoop fs -text /data/seq/metrics.seq
    10/07/14 06:02:53 INFO util.NativeCodeLoader: Loaded the native-hadoop library
    10/07/14 06:02:53 WARN zlib.ZlibFactory: Failed to load/initialize native-zlib l
ibrary
    10/07/14 06:02:53 INFO compress.CodecPool: Got brand-new decompressor

    .....



I moved everything out of lib/native/Linux-amd64/ then linked the libhadoop to libz.
ldd liobhadoop.so shows this:



    [root@namenode]# ldd libhadoop.so
       libc.so.6 => /lib64/tls/libc.so.6 (0x0000002a9569c000)
       /lib64/ld-linux-x86-64.so.2 (0x000000552aaaa000)


My 64-bit native lib looks like this:



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message