hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Khaled BEN BAHRI <Khaled.Ben_ba...@it-sudparis.eu>
Subject RE: Starting namenode
Date Wed, 02 Jun 2010 13:22:24 GMT
Hi,
When i started the namenode that gives these errors in logs file :
when i want to enter in the safe mode it also fail and gives that it  
can't connect to server

org.apache.hadoop.hdfs.server.namenode.DecommissionManager:  
Interrupted Monitor
java.lang.InterruptedException: sleep interrupted
         at java.lang.Thread.sleep(Native Method)
         at  
org.apache.hadoop.hdfs.server.namenode.DecommissionManager$Monitor.run(DecommissionManager.java:65)
         at java.lang.Thread.run(Thread.java:619)
2010-06-02 14:13:21,079 INFO org.apache.hadoop.ipc.Server: Stopping  
server on 9000
2010-06-02 14:13:21,079 ERROR  
org.apache.hadoop.hdfs.server.namenode.NameNode:  
java.net.BindException: Address already in use
         at sun.nio.ch.Net.bind(Native Method)
         at  
sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:119)
         at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:59)
         at  
org.mortbay.jetty.nio.SelectChannelConnector.open(SelectChannelConnector.java:216)
         at org.apache.hadoop.http.HttpServer.start(HttpServer.java:425)
         at  
org.apache.hadoop.hdfs.server.namenode.NameNode.startHttpServer(NameNode.java:246)
         at  
org.apache.hadoop.hdfs.server.namenode.NameNode.initialize(NameNode.java:202)
         at  
org.apache.hadoop.hdfs.server.namenode.NameNode.<init>(NameNode.java:279)
         at  
org.apache.hadoop.hdfs.server.namenode.NameNode.createNameNode(NameNode.java:956)
         at  
org.apache.hadoop.hdfs.server.namenode.NameNode.main(NameNode.java:965)



Thanks in advance
    Khaled


Quoting Sagar Shukla <sagar_shukla@persistent.co.in>:

> Hi Khaled,
>       Errors are usually thrown in logs/hadoop-hadoop-namenode.log   
> file. Please check for the causes of why namenode startup failed.
>
> If you face problems debugging, you can post it here and we can help  
>  you debug.
>
> Thanks,
> Sagar
>
> -----Original Message-----
> From: Khaled BEN BAHRI [mailto:Khaled.Ben_bahri@it-sudparis.eu]
> Sent: Wednesday, June 02, 2010 5:49 PM
> To: common-user@hadoop.apache.org
> Subject: Starting namenode
>
> Hi,
>
> When i started hadoop daemons with start-dfs.sh
> the namenode fail to run
>
> only the secondarynamenode and the datanode run
> what is the problem here and how can i run the namenode??
>
> thanks a lot for any help :)
>
> khaled
>
>
> DISCLAIMER
> ==========
> This e-mail may contain privileged and confidential information   
> which is the property of Persistent Systems Ltd. It is intended only  
>  for the use of the individual or entity to which it is addressed.  
> If  you are not the intended recipient, you are not authorized to  
> read,  retain, copy, print, distribute or use this message. If you  
> have  received this communication in error, please notify the sender  
> and  delete all copies of this message. Persistent Systems Ltd. does  
> not  accept any liability for virus infected mails.
>




Mime
View raw message