hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ninad Raut <hbase.user.ni...@gmail.com>
Subject Re: Cloudera AMIs
Date Tue, 16 Mar 2010 11:09:47 GMT
Hi,

Just copy the 0.20 Hadoop Folder to the EC2 master server (as u do it with
any other Unix Machine). Then create an AMI of the Installation and store it
in S3 for future use.

Create a R-sync script to sync ur Hadoop folders on Master and Slaves.

Regards,
Ninad R

On Tue, Mar 16, 2010 at 12:01 PM, Sonal Goyal <sonalgoyal4@gmail.com> wrote:

> Thanks Tom. I actually wanted to install Hadoop 0.20, or the Cloudera
> version which supports that. My application is written using the latest
> APIs, which are not backward compatible with the 0.18 versions. I tried
> using:
>
> hadoop-ec2 launch-cluster --env REPO=Testing --env HADOOP_VERSION=0.20 but
> the EC2 instance does not have hadoop installed. I checked the master, and
> there is no hadoop user or any install of hadoop.
>
> Is there a way I can setup the 0.20 cluster, other than following all the
> steps ?
>
> Thanks and Regards,
> Sonal
>
>
> On Tue, Mar 16, 2010 at 10:51 AM, Tom White <tom@cloudera.com> wrote:
>
> > Hi Sonal,
> >
> > You should use the one with the later date. The Cloudera AMIs don't
> > actually have Hadoop installed on them, just Java and some other base
> > packages. Hadoop is installed at start up time; you can find more
> > information at http://archive.cloudera.com/docs/ec2.html.
> >
> > Cheers,
> > Tom
> >
> > P.S. For Cloudera-specific questions please consider using the
> > Cloudera forum at http://getsatisfaction.com/cloudera
> >
> > On Sun, Mar 14, 2010 at 7:03 AM, Sonal Goyal <sonalgoyal4@gmail.com>
> > wrote:
> > > Hi,
> > >
> > > I want to know which Cloudera AMI supports which Hadoop version. For
> > > example,
> > >
> > >
> >
> ami-2932d440:cloudera-ec2-hadoop-images/cloudera-hadoop-ubuntu-20090602-i386.manifest.xml
> > >
> > >
> > > ami-ed59bf84:
> > >
> >
> cloudera-ec2-hadoop-images/cloudera-hadoop-ubuntu-20090623-i386.manifest.xml
> > >
> > > Whats the difference between the two? Which Hadoop version do they
> > support?
> > > I need to use the 0.20+ release.
> > >
> > >
> > > Thanks and Regards,
> > > Sonal
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message