hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Stewart <robstewar...@googlemail.com>
Subject Unable to exit safe mode
Date Thu, 14 Jan 2010 13:41:45 GMT
Hi,

I'm having a slight issue with my Hadoop cluster. There are 32 nodes. I
have:
/usr/lib/hadoop/bin/stop-mapred.sh
/usr/lib/hadoop/bin/stop-dfs.sh
/usr/lib/hadoop/bin/start-dfs.sh
/usr/lib/hadoop/bin/start-mapred.sh

All worked perfectly, no errors.

I try and remove a file: hadoop dfs -rmr wordCountOutput.jaql

This returns: Cannot delete [the file]. Name node is in safe mode.

I tried to exit safemode manually. I get:
> hadoop dfsadmin -safemode leave
FileSystem is file:///

 The code generating this is:


 public void setSafeMode(String[] argv, int idx) throws IOException {
     final String safeModeUsage = "Usage: java DFSAdmin -safemode "
                                  + "[enter | leave | get]";
    if (!(fs instanceof DistributedFileSystem)) {
      System.out.println("FileSystem is " + fs.getName());
      return;
    }


What seems to be the issue? the HDFS is running, and I can browse the
filesystem, both via the command line and the Hadoop web interface.


Thanks...

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message