hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "pavel kolodin" <pavelkolodinhad...@gmail.com>
Subject Re: "dfsadmin -report" says that i need "Superuser privilege". What? :)
Date Tue, 01 Dec 2009 18:34:20 GMT
On Tue, 01 Dec 2009 12:46:44 -0000, Brian Bockelman <bbockelm@cse.unl.edu>  
wrote:

> Hey Pavel,
>
> The "admin" / superuser for hadoop is the username who launched the  
> daemons.
>
> So, if you do "ps faux | grep hadoop", you should see some Java  
> processes; the first column of the output tells you what user they are  
> running as.  That user is the super user.
>
> Since you are already trying this as user "hadoop", I'm guessing that  
> you need to run the command as root.
>

I am scared to start hadoop as root. Never tried this before (-; Don't  
understand logic that should make me do that... )
I had experience of launching Hadoop on other 2 couples of machines. I  
always started all processes as "hadoop".

When i was writing this message, my hadoop distro was compiled by user  
"root". Now i recompuled it as user "hadoop" and result is the same.

Also i tried start that report request as root - result the same.

hadoopmaster hadoop # hadoop-0.20.1/bin/hadoop dfsadmin -report
report: org.apache.hadoop.security.AccessControlException: Superuser  
privilege is required
hadoopmaster hadoop #

I had beed using hadoop-0.20.1 on other couple of machines, result was  
another, this "-report" command was working.

Also, now i am experimenting with 2 VPS hosts, 64 bit, gentoo. Previous  
machines (i was successful with) was 32 bit, not VPS )

Thank you for answer.

Mime
View raw message