hadoop-common-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Farhan Husain <farhan.hus...@csebuet.org>
Subject Re: Web Interface Not Working
Date Tue, 15 Dec 2009 01:10:48 GMT
Guys,

I know this is a silly question but how do I bind the web interfaces to any
other hostname than localhost? I tried to find some documentation on it but
failed. Please help.

Thanks,
Farhan

On Thu, Dec 3, 2009 at 2:56 PM, Mark Vigeant
<mark.vigeant@riskmetrics.com>wrote:

> Thanks Steve!
>
> It's all working now. The problem was that I 2 different webapps folders
> for whatever reason and it was reading the "wrong one"
>
> -Mark
>
> -----Original Message-----
> From: Steve Loughran [mailto:stevel@apache.org]
> Sent: Wednesday, December 02, 2009 5:21 AM
> To: common-user@hadoop.apache.org
> Subject: Re: Web Interface Not Working
>
> Mark Vigeant wrote:
> > Todd,
> >
> > I followed your suggestion, shut down everything, restarted it, and the
> UI is still not there. Jps shows NN and JT working though.
> >
>
> Web UI is precompiled JSP on jetty; the rest of the system doesn't need
> it, and if the JSP JARs aren't on the classpath, Jetty won't behave.
>  * make sure that you have only one version of Jetty on your classpath
>  * make sure you only have one set of JSP JARs on the CP
>  * make sure the jetty jars are all consistent (not mixing versions)
>  * check that the various servlets are live (the TT and DNs have them).
> No servlets: jetty is down.
>
> I think you can tell Jetty to log at more detail, worth doing if you are
> trying to track down problems.
>
> This email message and any attachments are for the sole use of the intended
> recipients and may contain proprietary and/or confidential information which
> may be privileged or otherwise protected from disclosure. Any unauthorized
> review, use, disclosure or distribution is prohibited. If you are not an
> intended recipient, please contact the sender by reply email and destroy the
> original message and any copies of the message as well as any attachments to
> the original message.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message